Site Performance
Incident Report for Coinbase Custody
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 15:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2024 - 14:12 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 13, 2024 - 14:12 UTC
Investigating
We are aware that customers may be experiencing increased latency across Coinbase login, buy and sell. Rest assured, your funds are safe. Our team is investigating this issue and will provide an update shortly
Posted Feb 13, 2024 - 13:52 UTC