Delayed Base Deposits
Incident Report for Coinbase Custody
Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 00:56 UTC
Investigating
Delayed receives for Base. While we work on a fix, your funds remain secure.
Posted Aug 18, 2023 - 00:19 UTC