US, UK, DE Customers unable to add PayPal as payment method
Incident Report for Coinbase Custody
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 02:29 UTC
Identified
Please use an alternate payment method while our teams work on a fix.
Posted Aug 16, 2023 - 16:16 UTC