Delayed transactions - Algorand (ALGO)
Incident Report for Coinbase Custody
Resolved
This incident has been resolved.
Posted Nov 25, 2023 - 05:14 UTC
Investigating
Sends/receives are delayed for Algorand (ALGO). While we work on a fix, your funds remain secure.
Posted Nov 24, 2023 - 23:12 UTC
This incident affected: Digital Currencies (Algorand).