Delayed Arbitrum Withdrawals
Incident Report for Coinbase Custody
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 21:14 UTC
Investigating
Delayed withdrawals for Arbitrum. While we work on a fix, your funds remain secure.
Posted Aug 16, 2023 - 07:34 UTC